This project has moved and is read-only. For the latest updates, please go here.

Posting article error

Apr 17, 2011 at 12:28 PM

I got this error, when I try to post article into technet forum. Any ideas?

L.

Error in DataProvider.PostArticle: Exception:
Type System.ServiceModel.FaultException`1[[System.ServiceModel.ExceptionDetail, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]
Source: mscorlib
Message: Exception of type 'Microsoft.Com.Forums.Security.NotAuthorizedException' was thrown.
Stack-Trace:

Server stack trace:
   at System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter)
   at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at CommunityForumsNNTPServer.WebServiceDataSource.Forums.IForumsService.CreateQuestionThread(Guid forumId, String title, String body)
   at CommunityForumsNNTPServer.WebServiceDataSource.Forums.ForumsServiceClient.CreateQuestionThread(Guid forumId, String title, String body)
   at CommunityForumsNNTPServer.ForumDataSource.SaveArticles(String clientUsername, List`1 articles)
   at CommunityForumsNNTPServer.NNTPServer.DataProvider.PostArticle(String clientUsername, String data)

Apr 17, 2011 at 1:07 PM

Normally this happens, if the thread was moved or locked…

Apr 17, 2011 at 3:25 PM
Visit the forum on the web and check whether the thread has been locked or moved, or the post you're responding to deleted.
Noel
Apr 18, 2011 at 12:23 AM

My post should start new thread.

L.

Apr 18, 2011 at 5:54 AM

Then you are not allowed to post to this forum. Which forum did you want to post to?

Apr 18, 2011 at 12:53 PM

Msdn.en-US.netservices

I never before post message into this group. Is this group somehow limited?

L.