Error - System.FormatException

Feb 27, 2011 at 12:03 PM

Can ayone assit me fix this error? I'm a long time user currently on V1.1.43 - been getting this error for a few days.

ClientConnected
[Client: 9] ClassifyCommand: MODE READER
[Client: 9] Received: Command: MODE, Parameters: READER
[Client: 9] Received: Response: 200 Community Forums NNTP Server 1.1.43.0 Ready - posting allowed

[Client: 9] ClassifyCommand: GROUP Answers.en-US.w7hardware
[Client: 9] Received: Command: GROUP, Parameters: Answers.en-US.w7hardware
[Client 9] Server.OnDataReceived failed: Exception:
Type System.FormatException
Source: mscorlib
Message: Input string was not in a correct format.
Stack-Trace:
   at System.Text.StringBuilder.FormatError()
   at System.Text.StringBuilder.AppendFormat(IFormatProvider provider, String format, Object[] args)
   at System.String.Format(IFormatProvider provider, String format, Object[] args)
   at System.Diagnostics.TraceListener.TraceEvent(TraceEventCache eventCache, String source, TraceEventType eventType, Int32 id, String format, Object[] args)
   at System.Diagnostics.TraceSource.TraceEvent(TraceEventType eventType, Int32 id, String format, Object[] args)
   at CommunityForumsNNTPServer.NNTPServer.Traces.NntpServerTraceEvent(TraceEventType eventType, String format, Object[] args)
   at CommunityForumsNNTPServer.NNTPServer.NntpServer.DataReceived(String data, Int32 clientNumber)
   at CommunityForumsNNTPServer.NNTPServer.Server.OnDataReceived(IAsyncResult ar)

Coordinator
Feb 27, 2011 at 12:06 PM
The Answers-Forum does not support the WenService anymore... Please remove all answers newsgroups from your newsreader... And complain at microsoft.

Greetings
Jochen




Von: GrahamU <notifications@codeplex.com>
Gesendet: Sonntag, 27. Februar 2011 14:03
An: jochen@kalmbachnet.de <jochen@kalmbachnet.de>
Betreff: Error - System.FormatException [communitybridge:247746]

From: GrahamU

Can ayone assit me fix this error? I'm a long time user currently on V1.1.43 - been getting this error for a few days.

ClientConnected
[Client: 9] ClassifyCommand: MODE READER
[Client: 9] Received: Command: MODE, Parameters: READER
[Client: 9] Received: Response: 200 Community Forums NNTP Server 1.1.43.0 Ready - posting allowed

[Client: 9] ClassifyCommand: GROUP Answers.en-US.w7hardware
[Client: 9] Received: Command: GROUP, Parameters: Answers.en-US.w7hardware
[Client 9] Server.OnDataReceived failed: Exception:
Type System.FormatException
Source: mscorlib
Message: Input string was not in a correct format.
Stack-Trace:
at System.Text.StringBuilder.FormatError()
at System.Text.StringBuilder.AppendFormat(IFormatProvider provider, String format, Object[] args)
at System.String.Format(IFormatProvider provider, String format, Object[] args)
at System.Diagnostics.TraceListener.TraceEvent(TraceEventCache eventCache, String source, TraceEventType eventType, Int32 id, String format, Object[] args)
at System.Diagnostics.TraceSource.TraceEvent(TraceEventType eventType, Int32 id, String format, Object[] args)
at CommunityForumsNNTPServer.NNTPServer.Traces.NntpServerTraceEvent(TraceEventType eventType, String format, Object[] args)
at CommunityForumsNNTPServer.NNTPServer.NntpServer.DataReceived(String data, Int32 clientNumber)
at CommunityForumsNNTPServer.NNTPServer.Server.OnDataReceived(IAsyncResult ar)

Feb 27, 2011 at 12:07 PM

I suspect this has something to do with the new Answers forum interface which seems to have disabled NNTP access.  If anything, this web interface is less friendly for contributors than the previous, in my opinion.  I see no sign that NNTP access will be restored :-(

 

Mar 14, 2011 at 10:56 AM

I have similar problem whe try to access Technet forum:


ClientConnected
[Client: 6] ClassifyCommand: MODE READER
[Client: 6] Received: Command: MODE, Parameters: READER
[Client: 6] Received: Response: 200 Community Forums NNTP Server 1.1.43.0 Ready - posting allowed

[Client: 6] ClassifyCommand: GROUP Technet.cs-CZ.windows7cs
[Client: 6] Received: Command: GROUP, Parameters: Technet.cs-CZ.windows7cs
[Client 6] Server.OnDataReceived failed: Exception:
Type System.FormatException
Source: mscorlib
Message: Input string was not in a correct format.
Stack-Trace:
   at System.Text.StringBuilder.FormatError()
   at System.Text.StringBuilder.AppendFormat(IFormatProvider provider, String format, Object[] args)
   at System.String.Format(IFormatProvider provider, String format, Object[] args)
   at System.Diagnostics.TraceListener.TraceEvent(TraceEventCache eventCache, String source, TraceEventType eventType, Int32 id, String format, Object[] args)
   at System.Diagnostics.TraceSource.TraceEvent(TraceEventType eventType, Int32 id, String format, Object[] args)
   at CommunityForumsNNTPServer.NNTPServer.Traces.NntpServerTraceEvent(TraceEventType eventType, String format, Object[] args)
   at CommunityForumsNNTPServer.NNTPServer.NntpServer.DataReceived(String data, Int32 clientNumber)
   at CommunityForumsNNTPServer.NNTPServer.Server.OnDataReceived(IAsyncResult ar)

Coordinator
Mar 14, 2011 at 11:00 AM

Currently the MSDN/TechNet-Forums have no connection to the MS database... The error you are seeing ist just from a small logging-bug. The web-service error can be found here:

http://communitybridge.codeplex.com/discussions/249567

So it is a MS problem... maybe they changed the database-servers over the weekend and did not update the web-service servers...