HTML Non-Breaking space in plain text messages

May 31, 2010 at 11:19 AM

Jochen,

I posted a similar message in the private newsreaderac group, but I'm not sure if you saw it. 

Using an old version of Netscape Messenger, there is a visible funny character (an A with a caret over it) that sometimes appears.

In Thunderbird, that character appears as a white space.

In Netscape, I see:
I knew it would be simple.  Thanks much.
(there's an A with a caret over it after "simple.")

But in Tbird, it looks perfect:
I knew it would be simple.  Thanks much.

But I did a view source for both views of the message and it looks like the space after the dot is coming in as that HTML non-breaking space character (x160).

I think that this could be a problem (untested) when copying/pasting code taken from the messages directly into the VBE (or other editors).

Thanks for looking at it.

 

May 31, 2010 at 11:25 AM

I just tested it by finding a message that had the funny character in NS, but appeared ok in TBird.

Copying from TBird's window and pasting into the Excel's VBE worked fine.

Copying from NS's window and pasting into the Excel's VBE caused errors.

 

Coordinator
May 31, 2010 at 11:37 AM

I think NS is not aware of utf-8... maybe my future option to provide an encoding for the client, will help. Then you can set the encoding, and all characters will be "converted" accordingly..

May 31, 2010 at 12:11 PM

Thanks for looking at this, Jochen.

Coordinator
May 31, 2010 at 9:19 PM

Have you tried V19?

Also if it is not solved, you can now set an encoding in the advanced settings (for example: Windows-1252)

Greetings
  Jochen

May 31, 2010 at 9:47 PM

That looks perfect!

It looks good in the old version of NS and the newer TBird.

Netscape 4.79 had an encoding option of Western.  TBird is using Western (ISO 8859-1).

So even though Windows-1252 looked fine, I switched to ISO 8859-1.  I don't have any idea what those do differently, but I'm one happy camper.

Thanks a lot!